skel.ebuild 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # NOTE: The comments in this file are for instruction and documentation.
  4. # They're not meant to appear with your final, production ebuild. Please
  5. # remember to remove them before submitting or committing your ebuild. That
  6. # doesn't mean you can't add your own comments though.
  7. # The 'Header' on the third line should just be left alone. When your ebuild
  8. # will be committed to cvs, the details on that line will be automatically
  9. # generated to contain the correct data.
  10. # The EAPI variable tells the ebuild format in use.
  11. # Defaults to 0 if not specified.
  12. # It is suggested that you use the latest EAPI approved by the Council.
  13. # The PMS contains specifications for all EAPIs. Eclasses will test for this
  14. # variable if they need to use EAPI > 0 features.
  15. EAPI=5
  16. # inherit lists eclasses to inherit functions from. Almost all ebuilds should
  17. # inherit eutils, as a large amount of important functionality has been
  18. # moved there. For example, the epatch call mentioned below wont work
  19. # without the following line:
  20. inherit eutils
  21. # A well-used example of an eclass function that needs eutils is epatch. If
  22. # your source needs patches applied, it's suggested to put your patch in the
  23. # 'files' directory and use:
  24. #
  25. # epatch "${FILESDIR}"/patch-name-here
  26. #
  27. # eclasses tend to list descriptions of how to use their functions properly.
  28. # take a look at /usr/portage/eclass/ for more examples.
  29. # Short one-line description of this package.
  30. DESCRIPTION="This is a sample skeleton ebuild file"
  31. # Homepage, not used by Portage directly but handy for developer reference
  32. HOMEPAGE="http://foo.example.org/"
  33. # Point to any required sources; these will be automatically downloaded by
  34. # Portage.
  35. SRC_URI="ftp://foo.example.org/${P}.tar.gz"
  36. # License of the package. This must match the name of file(s) in
  37. # /usr/portage/licenses/. For complex license combination see the developer
  38. # docs on gentoo.org for details.
  39. LICENSE=""
  40. # The SLOT variable is used to tell Portage if it's OK to keep multiple
  41. # versions of the same package installed at the same time. For example,
  42. # if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
  43. # with 1.2.2), it would be optimal to instruct Portage to not remove
  44. # libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
  45. # we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
  46. # emerge clean understands SLOTs, and will keep the most recent version
  47. # of each SLOT and remove everything else.
  48. # Note that normal applications should use SLOT="0" if possible, since
  49. # there should only be exactly one version installed at a time.
  50. # DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
  51. SLOT="0"
  52. # Using KEYWORDS, we can record masking information *inside* an ebuild
  53. # instead of relying on an external package.mask file. Right now, you should
  54. # set the KEYWORDS variable for every ebuild so that it contains the names of
  55. # all the architectures with which the ebuild works. All of the official
  56. # architectures can be found in the arch.list file which is in
  57. # /usr/portage/profiles/. Usually you should just set this to "~x86". The ~
  58. # in front of the architecture indicates that the package is new and should be
  59. # considered unstable until testing proves its stability. So, if you've
  60. # confirmed that your ebuild works on x86 and ppc, you'd specify:
  61. # KEYWORDS="~x86 ~ppc"
  62. # Once packages go stable, the ~ prefix is removed.
  63. # For binary packages, use -* and then list the archs the bin package
  64. # exists for. If the package was for an x86 binary package, then
  65. # KEYWORDS would be set like this: KEYWORDS="-* x86"
  66. # DO NOT USE KEYWORDS="*". This is deprecated and only for backward
  67. # compatibility reasons.
  68. KEYWORDS="~x86"
  69. # Comprehensive list of any and all USE flags leveraged in the ebuild,
  70. # with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
  71. # "x86" and "alpha". Not needed if the ebuild doesn't use any USE flags.
  72. IUSE="gnome X"
  73. # A space delimited list of portage features to restrict. man 5 ebuild
  74. # for details. Usually not needed.
  75. #RESTRICT="strip"
  76. # Build-time dependencies, such as
  77. # ssl? ( >=dev-libs/openssl-0.9.6b )
  78. # >=dev-lang/perl-5.6.1-r1
  79. # It is advisable to use the >= syntax show above, to reflect what you
  80. # had installed on your system when you tested the package. Then
  81. # other users hopefully won't be caught without the right version of
  82. # a dependency.
  83. #DEPEND=""
  84. # Run-time dependencies. Must be defined to whatever this depends on to run.
  85. # The below is valid if the same run-time depends are required to compile.
  86. RDEPEND="${DEPEND}"
  87. # Source directory; the dir where the sources can be found (automatically
  88. # unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
  89. # If you don't need to change it, leave the S= line out of the ebuild
  90. # to keep it tidy.
  91. #S=${WORKDIR}/${P}
  92. # The following src_configure function is implemented as default by portage, so
  93. # you only need to call it if you need a different behaviour.
  94. # This function is available only in EAPI 2 and later.
  95. #src_configure() {
  96. # Most open-source packages use GNU autoconf for configuration.
  97. # The default, quickest (and preferred) way of running configure is:
  98. #econf
  99. #
  100. # You could use something similar to the following lines to
  101. # configure your package before compilation. The "|| die" portion
  102. # at the end will stop the build process if the command fails.
  103. # You should use this at the end of critical commands in the build
  104. # process. (Hint: Most commands are critical, that is, the build
  105. # process should abort if they aren't successful.)
  106. #./configure \
  107. # --host=${CHOST} \
  108. # --prefix=/usr \
  109. # --infodir=/usr/share/info \
  110. # --mandir=/usr/share/man || die
  111. # Note the use of --infodir and --mandir, above. This is to make
  112. # this package FHS 2.2-compliant. For more information, see
  113. # http://www.pathname.com/fhs/
  114. #}
  115. # The following src_compile function is implemented as default by portage, so
  116. # you only need to call it, if you need different behaviour.
  117. # For EAPI < 2 src_compile runs also commands currently present in
  118. # src_configure. Thus, if you're using an older EAPI, you need to copy them
  119. # to your src_compile and drop the src_configure function.
  120. #src_compile() {
  121. # emake (previously known as pmake) is a script that calls the
  122. # standard GNU make with parallel building options for speedier
  123. # builds (especially on SMP systems). Try emake first. It might
  124. # not work for some packages, because some makefiles have bugs
  125. # related to parallelism, in these cases, use emake -j1 to limit
  126. # make to a single process. The -j1 is a visual clue to others
  127. # that the makefiles have bugs that have been worked around.
  128. #emake || die
  129. #}
  130. # The following src_install function is implemented as default by portage, so
  131. # you only need to call it, if you need different behaviour.
  132. # For EAPI < 4 src_install is just returing true, so you need to always specify
  133. # this function in older EAPIs.
  134. #src_install() {
  135. # You must *personally verify* that this trick doesn't install
  136. # anything outside of DESTDIR; do this by reading and
  137. # understanding the install part of the Makefiles.
  138. # This is the preferred way to install.
  139. #emake DESTDIR="${D}" install || die
  140. # When you hit a failure with emake, do not just use make. It is
  141. # better to fix the Makefiles to allow proper parallelization.
  142. # If you fail with that, use "emake -j1", it's still better than make.
  143. # For Makefiles that don't make proper use of DESTDIR, setting
  144. # prefix is often an alternative. However if you do this, then
  145. # you also need to specify mandir and infodir, since they were
  146. # passed to ./configure as absolute paths (overriding the prefix
  147. # setting).
  148. #emake \
  149. # prefix="${D}"/usr \
  150. # mandir="${D}"/usr/share/man \
  151. # infodir="${D}"/usr/share/info \
  152. # libdir="${D}"/usr/$(get_libdir) \
  153. # install || die
  154. # Again, verify the Makefiles! We don't want anything falling
  155. # outside of ${D}.
  156. # The portage shortcut to the above command is simply:
  157. #
  158. #einstall || die
  159. #}