caribou-0.4.20.ebuild 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME2_LA_PUNT="yes"
  6. PYTHON_COMPAT=( python2_7 )
  7. PYTHON_REQ_USE="xml"
  8. inherit gnome2 python-r1
  9. DESCRIPTION="Input assistive technology intended for switch and pointer users"
  10. HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
  11. LICENSE="LGPL-2.1"
  12. SLOT="0"
  13. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  14. IUSE=""
  15. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  16. COMMON_DEPEND="
  17. app-accessibility/at-spi2-core
  18. >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
  19. >=x11-libs/gtk+-3:3[introspection]
  20. x11-libs/gtk+:2
  21. >=dev-libs/gobject-introspection-0.10.7:=
  22. dev-libs/libgee:0.8
  23. dev-libs/libxml2
  24. >=media-libs/clutter-1.5.11:1.0[introspection]
  25. x11-libs/libX11
  26. x11-libs/libxklavier
  27. x11-libs/libXtst
  28. "
  29. # gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
  30. # pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
  31. # librsvg needed to load svg images in css styles
  32. RDEPEND="${COMMON_DEPEND}
  33. dev-libs/glib[dbus]
  34. >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
  35. >=gnome-base/gsettings-desktop-schemas-3
  36. gnome-base/librsvg:2
  37. sys-apps/dbus
  38. "
  39. DEPEND="${COMMON_DEPEND}
  40. dev-libs/libxslt
  41. >=dev-util/intltool-0.35.5
  42. virtual/pkgconfig
  43. "
  44. src_prepare() {
  45. # delete custom PYTHONPATH, useless on Gentoo and potential bug source
  46. # + caribou is python2 only so fix the shell scripts
  47. sed -e '/export PYTHONPATH=.*python/ d' \
  48. -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
  49. -i bin/{antler-keyboard,caribou-preferences}.in ||
  50. die "sed failed"
  51. gnome2_src_prepare
  52. prepare_caribou() {
  53. mkdir -p "${BUILD_DIR}" || die
  54. }
  55. python_foreach_impl prepare_caribou
  56. }
  57. src_configure() {
  58. ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
  59. gnome2_src_configure \
  60. --disable-docs \
  61. --disable-static \
  62. --enable-gtk3-module \
  63. --enable-gtk2-module \
  64. VALAC=$(type -P true)
  65. # vala is not needed for tarball builds, but configure checks for it...
  66. }
  67. src_compile() {
  68. python_foreach_impl run_in_build_dir gnome2_src_compile
  69. }
  70. src_test() {
  71. python_foreach_impl run_in_build_dir default
  72. }
  73. src_install() {
  74. python_foreach_impl run_in_build_dir gnome2_src_install
  75. dodoc AUTHORS NEWS README # ChangeLog simply points to git log
  76. }