advancecomp-1.20.ebuild 911 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Recompress ZIP, PNG and MNG, considerably improving compression"
  6. HOMEPAGE="http://www.advancemame.it/comp-readme.html"
  7. SRC_URI="https://github.com/amadvance/${PN}/releases/download/v${PV}/${P}.tar.gz"
  8. LICENSE="GPL-3 LGPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
  11. IUSE="mng png test"
  12. RDEPEND="app-arch/bzip2
  13. sys-libs/zlib"
  14. DEPEND="${RDEPEND}"
  15. # test? (
  16. # app-text/tofrodos
  17. # dev-util/valgrind
  18. # )"
  19. RESTRICT="test" #282441, #523212
  20. src_configure() {
  21. econf --enable-bzip2 \
  22. $(use_enable test valgrind)
  23. }
  24. src_install() {
  25. dobin advdef advzip
  26. if use png; then
  27. dobin advpng
  28. doman doc/advpng.1
  29. fi
  30. if use mng; then
  31. dobin advmng
  32. doman doc/advmng.1
  33. fi
  34. dodoc HISTORY AUTHORS README
  35. doman doc/advdef.1 doc/advzip.1
  36. }