gzip-1.6.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils flag-o-matic
  5. DESCRIPTION="Standard GNU compressor"
  6. HOMEPAGE="https://www.gnu.org/software/gzip/"
  7. SRC_URI="mirror://gnu-alpha/gzip/${P}.tar.xz
  8. mirror://gnu/gzip/${P}.tar.xz
  9. mirror://gentoo/${P}.tar.xz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  13. IUSE="pic static"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
  16. epatch "${FILESDIR}"/${PN}-1.4-asmv.patch
  17. }
  18. src_configure() {
  19. use static && append-flags -static
  20. # avoid text relocation in gzip
  21. use pic && export DEFS="NO_ASM"
  22. econf
  23. }
  24. src_install() {
  25. default
  26. docinto txt
  27. dodoc algorithm.doc gzip.doc
  28. # keep most things in /usr, just the fun stuff in /
  29. dodir /bin
  30. mv "${ED}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${ED}"/bin/ || die
  31. sed -e "s:${EPREFIX}/usr:${EPREFIX}:" -i "${ED}"/bin/gunzip || die
  32. }