unrpa-1.4.1.ebuild 597 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. if [[ ${PV} == "9999" ]] ; then
  7. inherit git-r3
  8. EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
  9. else
  10. SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  11. KEYWORDS="~amd64 ~x86"
  12. fi
  13. DESCRIPTION="Ren'Py's RPA data file extractor"
  14. HOMEPAGE="https://github.com/Lattyware/unrpa"
  15. LICENSE="GPL-3"
  16. SLOT="0"
  17. DEPEND="${PYTHON_DEPS}"
  18. RDEPEND=${DEPEND}
  19. src_install() {
  20. dobin ${PN}
  21. dodoc README
  22. }