borgbackup-9999.ebuild 921 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. PYTHON_COMPAT=( python3_{4,5} )
  5. inherit distutils-r1
  6. if [[ ${PV} == "9999" ]] ; then
  7. EGIT_REPO_URI="https://github.com/${PN}/borg.git"
  8. inherit git-r3
  9. else
  10. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  11. KEYWORDS="~amd64 ~x86"
  12. fi
  13. DESCRIPTION="Deduplicating backup program with compression and authenticated encryption."
  14. HOMEPAGE="https://borgbackup.readthedocs.io/"
  15. LICENSE="BSD"
  16. SLOT="0"
  17. IUSE="libressl +fuse"
  18. # Unformately we have a file conflict with app-office/borg, bug #580402
  19. RDEPEND="
  20. !!app-office/borg
  21. app-arch/lz4
  22. dev-python/msgpack[${PYTHON_USEDEP}]
  23. !libressl? ( dev-libs/openssl:0= )
  24. libressl? ( dev-libs/libressl:0= )
  25. fuse? ( dev-python/llfuse[${PYTHON_USEDEP}] )
  26. "
  27. DEPEND="
  28. dev-python/setuptools_scm[${PYTHON_USEDEP}]
  29. dev-python/cython[${PYTHON_USEDEP}]
  30. ${RDEPEND}
  31. "