holland-backup-example-1.0.10.ebuild 889 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="Holland Example Plugin"
  7. HOMEPAGE="http://www.hollandbackup.org/"
  8. MY_P="${P%%-*}-${P##*-}"
  9. SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${MY_P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  15. RDEPEND=""
  16. PDEPEND="~app-backup/holland-${PV}[${PYTHON_USEDEP}]"
  17. S="${WORKDIR}/${MY_P}/plugins/${PN//-/.}"
  18. python_install_all() {
  19. distutils-r1_python_install_all
  20. keepdir /etc/holland
  21. keepdir /etc/holland/backupsets
  22. keepdir /etc/holland/providers
  23. insinto /etc/holland/backupsets
  24. doins "${S}"/../../config/backupsets/examples/${PN##*-}.conf
  25. insinto /etc/holland/providers
  26. doins "${S}"/../../config/providers/${PN##*-}.conf
  27. }