cdck-0.7.0-r1.ebuild 716 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Measure the read time per sector on CD or DVD to check the quality"
  6. HOMEPAGE="http://swaj.net/unix/index.html#cdck"
  7. SRC_URI="http://swaj.net/unix/cdck/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. src_prepare() {
  13. sed -e '1d' -i man/cdck_man.in || die "sed failed"
  14. }
  15. src_configure() {
  16. econf --disable-dependency-tracking \
  17. --disable-shared || die "econf failed."
  18. }
  19. src_compile() {
  20. emake -j1 || die "emake failed."
  21. }
  22. src_install() {
  23. dobin src/cdck || die "dobin failed."
  24. doman man/cdck.1
  25. dodoc AUTHORS ChangeLog NEWS README THANKS TODO
  26. }