gkeys-9999.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=(python{2_7,3_4,3_5})
  5. #EGIT_PROJECT="gentoo-keys.git"
  6. EGIT_BRANCH="master"
  7. inherit distutils-r1 git-r3
  8. EGIT_REPO_URI="git://anongit.gentoo.org/proj/gentoo-keys.git"
  9. DESCRIPTION="An OpenPGP/GPG key management tool and python libs"
  10. HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
  11. SRC_URI=""
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. IUSE=""
  15. KEYWORDS=""
  16. DEPEND=""
  17. RDEPEND="${DEPEND}
  18. app-crypt/gnupg
  19. =dev-python/pyGPG-9999[${PYTHON_USEDEP}]
  20. =dev-python/ssl-fetch-9999[${PYTHON_USEDEP}]
  21. >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
  22. >=app-crypt/gentoo-keys-201501052117
  23. "
  24. S="${WORKDIR}/$P/gkeys"
  25. python_prepare_all() {
  26. distutils-r1_python_prepare_all
  27. # copy these 2 into our subdir from the master level
  28. cp ../LICENSE ./ || die "cp LICENSE failed"
  29. cp ../README.md ./ || die "cp README.me failed"
  30. cp -R ../py2man ./ || die "cp-R py2man failed"
  31. }
  32. python_install_all() {
  33. distutils-r1_python_install_all
  34. keepdir /var/log/gkeys
  35. fperms g+w /var/log/gkeys
  36. }
  37. pkg_preinst() {
  38. chgrp users "${D}"/var/log/gkeys
  39. }
  40. pkg_postinst() {
  41. einfo
  42. einfo "This is experimental software."
  43. einfo "The API's it installs should be considered unstable"
  44. einfo "and are subject to change."
  45. einfo
  46. einfo "Please file any enhancement requests, or bugs"
  47. einfo "at https://bugs.gentoo.org"
  48. einfo "We are also on IRC @ #gentoo-keys of the freenode network"
  49. einfo
  50. ewarn "There may be some python 3 compatibility issues still."
  51. ewarn "Please help debug/fix/report them in bugzilla."
  52. }