joe-4.2.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
  5. HOMEPAGE="https://sourceforge.net/projects/joe-editor/"
  6. SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
  7. LICENSE="GPL-1+ CC-BY-3.0"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
  10. IUSE="xterm"
  11. DEPEND=">=sys-libs/ncurses-5.2-r2"
  12. RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
  13. DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
  14. src_prepare() {
  15. default
  16. # Enable xterm mouse support in the rc files
  17. if use xterm; then
  18. cd "${S}"/rc
  19. for i in *rc*.in; do
  20. sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
  21. done
  22. fi
  23. }
  24. pkg_postinst() {
  25. if use xterm; then
  26. elog "To enable full xterm clipboard you need to set the allowWindowOps"
  27. elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
  28. elog "This is false by default due to potential security problems on some"
  29. elog "architectures (see bug #91453)."
  30. fi
  31. }