tea-43.1.0.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils qmake-utils
  5. DESCRIPTION="Small, lightweight Qt text editor"
  6. HOMEPAGE="http://tea.ourproject.org/"
  7. SRC_URI="http://tea.ourproject.org/dloads/${P}.tar.bz2"
  8. LICENSE="GPL-3+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~x86-fbsd"
  11. IUSE="aspell djvu hunspell pdf"
  12. RDEPEND="
  13. dev-qt/qtcore:5
  14. dev-qt/qtdeclarative:5
  15. dev-qt/qtgui:5
  16. dev-qt/qtnetwork:5
  17. dev-qt/qtprintsupport:5
  18. dev-qt/qtwidgets:5
  19. sys-libs/zlib
  20. aspell? ( app-text/aspell )
  21. djvu? ( app-text/djvu )
  22. hunspell? ( app-text/hunspell:= )
  23. pdf? ( app-text/poppler[qt5] )
  24. "
  25. DEPEND="${RDEPEND}
  26. hunspell? ( virtual/pkgconfig )
  27. "
  28. DOCS=( AUTHORS ChangeLog NEWS NEWS-RU TODO )
  29. src_configure() {
  30. eqmake5 src.pro \
  31. $(use aspell || echo CONFIG+=noaspell) \
  32. $(use djvu && echo CONFIG+=usedjvu) \
  33. $(use hunspell || echo CONFIG+=nohunspell) \
  34. $(use pdf && echo CONFIG+=usepoppler)
  35. }
  36. src_install() {
  37. dobin bin/tea
  38. einstalldocs
  39. docinto html
  40. dodoc manuals/*.html
  41. insinto /usr/share/qt5/translations
  42. doins translations/${PN}_*.qm
  43. newicon icons/tea-icon-v3-01.png ${PN}.png
  44. make_desktop_entry ${PN} 'Tea Editor'
  45. }