bijiben-3.21.2.ebuild 828 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="Note editor designed to remain simple to use"
  6. HOMEPAGE="https://wiki.gnome.org/Apps/Bijiben"
  7. LICENSE="GPL-3+"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="zeitgeist"
  11. RDEPEND="
  12. >=app-misc/tracker-1:=
  13. >=dev-libs/glib-2.28:2
  14. dev-libs/libxml2
  15. >=gnome-extra/evolution-data-server-3.13.90:=
  16. net-libs/gnome-online-accounts:=
  17. net-libs/webkit-gtk:3
  18. sys-apps/util-linux
  19. >=x11-libs/gtk+-3.11.4:3
  20. zeitgeist? ( gnome-extra/zeitgeist )
  21. "
  22. DEPEND="${RDEPEND}
  23. app-text/yelp-tools
  24. dev-libs/appstream-glib
  25. dev-util/gdbus-codegen
  26. >=dev-util/intltool-0.50.1
  27. sys-devel/gettext
  28. virtual/pkgconfig
  29. "
  30. src_configure() {
  31. gnome2_src_configure \
  32. $(use_enable zeitgeist) \
  33. --disable-update-mimedb
  34. }