eid-viewer-bin-4.0.7_p184.ebuild 733 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. MY_PN="eid-viewer"
  6. MY_PV="${PV%%_p*}"
  7. #MY_PV="${PV/_p/-}"
  8. MY_P="${MY_PN}-${MY_PV}"
  9. SLOT="0"
  10. LICENSE="LGPL-3"
  11. KEYWORDS="~amd64 ~x86"
  12. DESCRIPTION="Graphical interface to the Belgian Electronic Identity Card"
  13. SRC_URI="http://eid.belgium.be/en/binaries/eid-viewer-4%2E0%2E7-184%2Esrc%2Etar_tcm406-250014.gz -> eid-viewer-4.0.7_p184.tar.gz"
  14. HOMEPAGE="http://eid.belgium.be"
  15. RDEPEND="
  16. virtual/jre:*
  17. sys-apps/pcsc-lite"
  18. DEPEND="${RDEPEND}"
  19. IUSE=""
  20. S="${WORKDIR}/${MY_P}"
  21. src_prepare() {
  22. sed -i -e 's:icons:pixmaps:' Makefile.in || die
  23. sed -i -e 's:Application;::' eid-viewer.desktop.sh.in || die
  24. }