email2trac-2.8.4.ebuild 943 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="Utilities to convert emails to trac tickets"
  7. HOMEPAGE="https://oss.trac.surfsara.nl/email2trac"
  8. SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. RDEPEND="${PYTHON_DEPS}
  13. <www-apps/trac-1.2[${PYTHON_USEDEP}]"
  14. pkg_setup() {
  15. einfo "You can set the following variables in make.conf:"
  16. einfo " - EMAIL2TRAC_TRAC_USER (default: apache)"
  17. einfo " - EMAIL2TRAC_MTA_USER (default: nobody)"
  18. python-single-r1_pkg_setup
  19. }
  20. src_prepare() {
  21. sed -i -e "/^CFLAGS/s:=:&${CFLAGS} :" \
  22. -e "s:\$(CC):& ${LDFLAGS} :" \
  23. Makefile.in || die 'sed failed'
  24. }
  25. src_configure() {
  26. econf --sysconfdir=/etc/${PN}/ \
  27. --with-trac_user=${EMAIL2TRAC_TRAC_USER:-apache} \
  28. --with-mta_user=${EMAIL2TRAC_MTA_USER:-nobody}
  29. }