figlet-2.2.5.ebuild 944 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils bash-completion-r1 toolchain-funcs
  5. DESCRIPTION="program for making large letters out of ordinary text"
  6. HOMEPAGE="http://www.figlet.org/"
  7. SRC_URI="ftp://ftp.figlet.org/pub/figlet/program/unix/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE=""
  12. src_compile() {
  13. emake clean
  14. emake \
  15. CC="$(tc-getCC)" \
  16. LD="$(tc-getCC)" \
  17. CFLAGS="${CFLAGS}" \
  18. LDFLAGS="${LDFLAGS}" \
  19. prefix="${EPREFIX}/usr" \
  20. all
  21. }
  22. src_install() {
  23. emake \
  24. DESTDIR="${D}" \
  25. BINDIR="${EPREFIX}/usr/bin" \
  26. MANDIR="${EPREFIX}/usr/share/man" \
  27. prefix="${EPREFIX}/usr" \
  28. install
  29. doman chkfont.6 figlet.6 figlist.6 showfigfonts.6
  30. dodoc README figfont.txt
  31. dobashcomp "${FILESDIR}"/figlet.bashcomp
  32. }