no-more-secrets-9999.ebuild 758 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. #if [[ ${PV} == "9999" ]] ; then
  6. EGIT_REPO_URI="https://github.com/bartobri/${PN}.git"
  7. SRC_URI=""
  8. inherit git-r3
  9. KEYWORDS=""
  10. #else
  11. # SRC_URI=""
  12. # KEYWORDS=""
  13. #fi
  14. DESCRIPTION="recreate decrypting text from 1992 movie 'Sneakers'"
  15. HOMEPAGE="https://github.com/bartobri/no-more-secrets"
  16. LICENSE="GPL-3"
  17. SLOT=0
  18. DEPEND="sys-libs/ncurses:0="
  19. RDEPEND="${DEPEND}"
  20. src_prepare() {
  21. sed -i 's#CC =#CC ?=#' Makefile
  22. sed -i 's#prefix =#prefix ?=#' Makefile
  23. sed -i 's#CFLAGS =#CFLAGS ?=#' Makefile
  24. }
  25. src_compile() {
  26. CC=$(tc-getCC) CFLAGS=${CFLAGS} emake
  27. }
  28. src_install() {
  29. prefix=/usr DESTDIR="${ED}" emake install
  30. }