worker-3.8.3.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone"
  6. HOMEPAGE="http://www.boomerangsworld.de/cms/worker/"
  7. SRC_URI="http://www.boomerangsworld.de/cms/worker/downloads/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
  11. IUSE="avfs debug dbus examples libnotify lua +magic xinerama xft"
  12. RDEPEND="x11-libs/libX11
  13. avfs? ( >=sys-fs/avfs-0.9.5 )
  14. dbus? ( dev-libs/dbus-glib )
  15. lua? ( dev-lang/lua:0 )
  16. magic? ( sys-apps/file )
  17. xft? ( x11-libs/libXft )
  18. xinerama? ( x11-libs/libXinerama )"
  19. DEPEND="${RDEPEND}"
  20. DOCS=( AUTHORS ChangeLog INSTALL NEWS README README_LARGEFILES THANKS )
  21. src_configure() {
  22. # there is no ./configure flag to disable libXinerama support
  23. export ac_cv_lib_Xinerama_XineramaQueryScreens=$(usex xinerama)
  24. econf \
  25. --without-hal \
  26. --enable-utf8 \
  27. $(use_with avfs) \
  28. $(use_with dbus) \
  29. $(use_enable debug) \
  30. $(use_enable libnotify inotify) \
  31. $(use_enable lua) \
  32. $(use_with magic libmagic) \
  33. $(use_enable xft)
  34. }
  35. src_compile() {
  36. emake -j1
  37. }
  38. src_install() {
  39. default
  40. if use examples; then
  41. docinto examples
  42. dodoc examples/config-*
  43. fi
  44. }