dynamite-0.1.1_p20120512.ebuild 715 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils
  5. DESCRIPTION="A tool for decompressing data compressed with PKWARE Data Compression Library"
  6. HOMEPAGE="https://github.com/twogood/dynamite https://sourceforge.net/projects/synce/"
  7. SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE="static-libs"
  12. src_prepare() {
  13. epatch "${FILESDIR}"/${PN}-bootstrap.patch
  14. ./bootstrap
  15. eautoreconf
  16. }
  17. src_configure() {
  18. econf $(use_enable static-libs static)
  19. }
  20. src_install() {
  21. emake DESTDIR="${D}" install
  22. dodoc ChangeLog README
  23. find "${ED}" -name '*.la' -exec rm -f {} +
  24. }