localshell-1.3.4-r1.ebuild 797 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit base eutils
  5. DESCRIPTION="Localshell allows per-user/group local control of shell execution"
  6. HOMEPAGE="http://git.orbis-terrarum.net/?p=infrastructure/localshellc.git;a=summary"
  7. SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~ppc64"
  11. IUSE=""
  12. src_configure() {
  13. # this is a shell, it needs to be in /bin
  14. econf --bindir=/bin --sysconfdir=/etc
  15. }
  16. src_install() {
  17. emake install DESTDIR="${D}" || die "emake install failed"
  18. rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
  19. }
  20. pkg_postinst() {
  21. elog "Remember to add /bin/localshell to /etc/shells and create"
  22. elog "/etc/localshell.conf based on the included configuration examples"
  23. }