duali-0.2.0-r1.ebuild 962 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. # Duali uses "anydbm" which should even support a slow fallback;
  6. # however, due to implementation details it fails when the databases
  7. # aren't gdbm.
  8. PYTHON_REQ_USE="gdbm"
  9. inherit python-single-r1
  10. DESCRIPTION="Arabic dictionary based on the DICT protocol"
  11. HOMEPAGE="http://www.arabeyes.org/project.php?proj=Duali"
  12. SRC_URI="mirror://sourceforge/arabeyes/${P}.tar.bz2"
  13. LICENSE="BSD"
  14. SLOT="0"
  15. KEYWORDS="alpha amd64 ~hppa ~ia64 ~mips ~ppc ~sparc x86"
  16. IUSE=""
  17. DEPEND="${PYTHON_DEPS}"
  18. RDEPEND="${DEPEND}"
  19. PDEPEND=">=app-dicts/duali-data-0.1b-r1"
  20. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  21. src_install() {
  22. python_fix_shebang duali dict2db trans2arabic arabic2trans
  23. python_doexe duali dict2db trans2arabic arabic2trans
  24. insinto /etc
  25. doins duali.conf
  26. doman doc/man/*.1
  27. dodoc README ChangeLog
  28. python_domodule pyduali
  29. }