krop-0.4.8.ebuild 594 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils distutils-r1
  6. DESCRIPTION="A tool to crop PDF files"
  7. HOMEPAGE="http://arminstraub.com/software/krop"
  8. SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
  14. dev-python/pyPdf[${PYTHON_USEDEP}]
  15. dev-python/PyQt4[${PYTHON_USEDEP}]"
  16. src_install() {
  17. distutils-r1_src_install
  18. domenu "${WORKDIR}/${P}/${PN}.desktop"
  19. }