unpaper-5.1.ebuild 753 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. if [[ ${PV} == 9999 ]]; then
  5. EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
  6. inherit git-2 autotools
  7. else
  8. SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
  9. KEYWORDS="~amd64 ~x86"
  10. fi
  11. DESCRIPTION="Post-processor for scanned and photocopied book pages"
  12. HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
  13. LICENSE="GPL-2"
  14. SLOT="0"
  15. IUSE="test"
  16. DEPEND="test? ( media-libs/netpbm[png] )
  17. dev-libs/libxslt
  18. app-text/docbook-xsl-ns-stylesheets"
  19. RDEPEND=""
  20. if [[ ${PV} == 9999 ]]; then
  21. src_prepare() {
  22. eautoreconf
  23. }
  24. fi
  25. src_configure() {
  26. econf \
  27. --docdir=/usr/share/doc/${PF} \
  28. --htmldir=/usr/share/doc/${PF}/html
  29. }