xournal-0.4.8-r1.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. GCONF_DEBUG=no
  5. inherit gnome2
  6. DESCRIPTION="An application for notetaking, sketching, and keeping a journal using a stylus"
  7. HOMEPAGE="http://xournal.sourceforge.net/"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. IUSE="+pdf vanilla"
  11. if [[ "${PV}" != "9999" ]]; then
  12. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  13. KEYWORDS="~amd64 ~x86"
  14. else
  15. inherit git-2 autotools
  16. SRC_URI=""
  17. KEYWORDS=""
  18. EGIT_REPO_URI="git://git.code.sf.net/p/xournal/code"
  19. EGIT_PROJECT="${PN}"
  20. EGIT_BOOTSTRAP="autogen.sh"
  21. fi
  22. COMMONDEPEND="
  23. app-text/poppler:=[cairo]
  24. dev-libs/atk
  25. dev-libs/glib
  26. gnome-base/libgnomecanvas
  27. media-libs/freetype
  28. media-libs/fontconfig
  29. sys-libs/zlib
  30. x11-libs/cairo
  31. x11-libs/gdk-pixbuf
  32. x11-libs/gtk+:2
  33. x11-libs/pango
  34. "
  35. RDEPEND="${COMMONDEPEND}
  36. pdf? ( app-text/poppler[utils] app-text/ghostscript-gpl )
  37. "
  38. DEPEND="${COMMONDEPEND}
  39. virtual/pkgconfig
  40. "
  41. src_prepare() {
  42. default_src_prepare
  43. if ! use vanilla; then
  44. epatch "${FILESDIR}"/xournal-0.4.8-aspectratio.patch
  45. fi
  46. }
  47. src_install() {
  48. emake DESTDIR="${D}" install
  49. emake DESTDIR="${D}" desktop-install
  50. dodoc ChangeLog AUTHORS README
  51. dohtml -r html-doc/*
  52. }