ebnf-syntax-1.1-r1.ebuild 586 B

123456789101112131415161718192021
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit vim-plugin
  4. DESCRIPTION="vim plugin: EBNF (ISO/IEC 14997) file syntax highlighting"
  5. HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=545"
  6. LICENSE="vim"
  7. KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
  8. IUSE=""
  9. VIM_PLUGIN_HELPTEXT=\
  10. "This plugin provides syntax highlighting for EBNF (ISO/IEC 14997) files."
  11. src_unpack() {
  12. unpack ${A}
  13. cd "${S}"
  14. # don't use hi link, bug #101799.
  15. sed -i -e 's,hi link,hi def link,' syntax/ebnf.vim || die "sed failed"
  16. }