ebnf-syntax-1.1-r2.ebuild 588 B

1234567891011121314151617181920212223
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit vim-plugin
  5. DESCRIPTION="vim plugin: EBNF (ISO/IEC 14997) file syntax highlighting"
  6. HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=545"
  7. LICENSE="vim"
  8. KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
  9. IUSE=""
  10. VIM_PLUGIN_HELPTEXT=\
  11. "This plugin provides syntax highlighting for EBNF (ISO/IEC 14997) files."
  12. src_prepare() {
  13. default
  14. # don't use hi link, bug #101799.
  15. sed -i -e 's,hi link,hi def link,' syntax/ebnf.vim || die "sed failed"
  16. }