tlib-1.20.ebuild 565 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit vim-plugin
  5. MY_PN=${PN}_vim
  6. MY_P=${MY_PN}-${PV}
  7. DESCRIPTION="vim plugin: a library of utility functions"
  8. HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1863 https://github.com/tomtom/tlib_vim"
  9. SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. KEYWORDS="amd64 x86"
  12. VIM_PLUGIN_HELPFILES="${PN}.txt"
  13. S=${WORKDIR}/${MY_P}
  14. src_prepare() {
  15. rm -r test samples addon-info.json || die
  16. }