glibmm-2.50.0.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2 multilib-minimal
  5. DESCRIPTION="C++ interface for glib2"
  6. HOMEPAGE="http://www.gtkmm.org"
  7. LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
  8. SLOT="2"
  9. KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
  10. IUSE="doc debug test"
  11. RDEPEND="
  12. >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
  13. >=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}]
  14. "
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig
  17. doc? ( app-doc/doxygen )
  18. "
  19. # dev-cpp/mm-common needed for eautoreconf
  20. src_prepare() {
  21. if ! use test; then
  22. # don't waste time building tests
  23. sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
  24. -i Makefile.am Makefile.in || die "sed 1 failed"
  25. fi
  26. # don't build examples - we want to install example sources, not binaries
  27. sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
  28. -i Makefile.am Makefile.in || die "sed 2 failed"
  29. gnome2_src_prepare
  30. }
  31. multilib_src_configure() {
  32. ECONF_SOURCE="${S}" gnome2_src_configure \
  33. $(use_enable debug debug-refcounting) \
  34. $(multilib_native_use_enable doc documentation) \
  35. --enable-deprecated-api
  36. }
  37. multilib_src_test() {
  38. cd tests
  39. default
  40. for i in */test; do
  41. ${i} || die "Running tests failed at ${i}"
  42. done
  43. }
  44. multilib_src_install() {
  45. gnome2_src_install
  46. }
  47. multilib_src_install_all() {
  48. einstalldocs
  49. find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
  50. find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
  51. dodoc -r examples
  52. }