123456789101112131415161718192021222324252627282930313233343536 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- inherit cmake-utils
- DESCRIPTION="YAML parser and emitter in C++"
- HOMEPAGE="https://github.com/jbeder/yaml-cpp"
- SRC_URI="https://github.com/jbeder/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- LICENSE="MIT"
- SLOT="0"
- KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
- IUSE=""
- DEPEND=">=dev-libs/boost-1.49.0-r2"
- RDEPEND="${DEPEND}"
- S="${WORKDIR}/${PN}-release-${PV}"
- src_prepare() {
- sed -i \
- -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
- yaml-cpp.pc.cmake || die
- cmake-utils_src_prepare
- }
- src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- )
- cmake-utils_src_configure
- }
|