yaml-cpp-0.5.3.ebuild 741 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="YAML parser and emitter in C++"
  6. HOMEPAGE="https://github.com/jbeder/yaml-cpp"
  7. SRC_URI="https://github.com/jbeder/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. DEPEND=">=dev-libs/boost-1.49.0-r2"
  13. RDEPEND="${DEPEND}"
  14. S="${WORKDIR}/${PN}-release-${PV}"
  15. src_prepare() {
  16. sed -i \
  17. -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
  18. yaml-cpp.pc.cmake || die
  19. cmake-utils_src_prepare
  20. }
  21. src_configure() {
  22. local mycmakeargs=(
  23. -DBUILD_SHARED_LIBS=ON
  24. )
  25. cmake-utils_src_configure
  26. }