gigabase-3.83-r2.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
  5. HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
  6. SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="doc static-libs"
  11. DEPEND="doc? ( app-doc/doxygen )"
  12. RDEPEND=""
  13. S="${WORKDIR}/${PN}"
  14. PATCHES=(
  15. "${FILESDIR}/${P}-fix-dereferencing.patch"
  16. "${FILESDIR}/${P}-cpp14.patch" # fix #594550
  17. "${FILESDIR}/${P}-fix-build-system.patch"
  18. )
  19. src_configure() {
  20. econf $(use_enable static-libs static)
  21. }
  22. src_compile() {
  23. default
  24. if use doc; then
  25. doxygen doxygen.cfg || die
  26. HTML_DOCS=( GigaBASE.htm docs/html/. )
  27. fi
  28. }
  29. src_test() {
  30. local t
  31. for t in testddl testidx testidx2 testiref testleak testperf \
  32. testperf2 testspat testtl testsync testtimeseries; do
  33. ./${t} || die
  34. done
  35. }
  36. src_install() {
  37. default
  38. if ! use static-libs; then
  39. find "${D}" -name '*.la' -delete || die
  40. fi
  41. }
  42. pkg_postinst() {
  43. elog "The subsql binary has been renamed to subsql-gdb,"
  44. elog "to avoid a name clash with the FastDB version of subsql"
  45. }