m17n-contrib-1.1.14.ebuild 670 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="Contribution database for the m17n library"
  5. HOMEPAGE="https://savannah.nongnu.org/projects/m17n"
  6. SRC_URI="http://download.savannah.gnu.org/releases/m17n/${P}.tar.gz"
  7. LICENSE="LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE=""
  11. DEPEND=""
  12. # Strict version to avoid collision
  13. RDEPEND=">=dev-db/m17n-db-1.6.4"
  14. src_configure() {
  15. # force the script not to test for m17n presence, trust Portage
  16. # dependency handling.
  17. export HAVE_M17N_DB=yes
  18. econf
  19. }
  20. src_install() {
  21. emake DESTDIR="${D}" install || die
  22. dodoc AUTHORS ChangeLog NEWS README
  23. }