fast_xml-1.1.22.ebuild 577 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit rebar
  5. DESCRIPTION="Fast Expat based Erlang XML parsing library"
  6. HOMEPAGE="https://github.com/processone/fast_xml"
  7. SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
  8. -> ${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
  12. IUSE="test"
  13. RDEPEND=">=dev-erlang/p1_utils-1.0.7
  14. >=dev-lang/erlang-17.1
  15. dev-libs/expat"
  16. DEPEND="${RDEPEND}
  17. test? ( >=dev-lang/elixir-1.1 )"
  18. DOCS=( CHANGELOG.md README.md )