coveraggregator-0_pre20170216.ebuild 553 B

1234567891011121314151617181920212223
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit golang-build golang-vcs-snapshot
  5. KEYWORDS="~amd64"
  6. EGO_PN=github.com/chouquette/${PN}
  7. HOMEPAGE="https://${EGO_PN}"
  8. EGIT_COMMIT="af12d4d73479a1b49a16bbed8e5c182999dd62be"
  9. SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
  10. DESCRIPTION="Cover profile aggregator for golang"
  11. LICENSE="WTFPL-2"
  12. SLOT="0"
  13. IUSE=""
  14. DEPEND="dev-go/go-tools:="
  15. RDEPEND=""
  16. src_install() {
  17. dobin ${PN}
  18. dodoc src/${EGO_PN}/README.md
  19. }