async-2.0.1.4.ebuild 832 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.3.9999
  5. CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
  6. inherit haskell-cabal
  7. DESCRIPTION="Run IO operations asynchronously and wait for their results"
  8. HOMEPAGE="https://github.com/simonmar/async"
  9. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0/${PV}"
  12. KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
  13. IUSE=""
  14. RDEPEND=">=dev-haskell/stm-2.2:=[profile?]
  15. <dev-haskell/stm-2.5:=[profile?]
  16. >=dev-lang/ghc-7.0.1:="
  17. DEPEND="${RDEPEND}
  18. test? ( dev-haskell/hunit
  19. dev-haskell/test-framework
  20. dev-haskell/test-framework-hunit
  21. )
  22. >=dev-haskell/cabal-1.8"
  23. src_prepare() {
  24. cabal_chdeps \
  25. 'base >= 4.3 && < 4.7' 'base >= 4.3'
  26. }