cairo-0.12.5.3.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.3.5.9999
  5. CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
  6. inherit haskell-cabal
  7. DESCRIPTION="Binding to the Cairo library"
  8. HOMEPAGE="http://projects.haskell.org/gtk2hs/"
  9. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0/${PV}"
  12. KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
  13. IUSE="+pdf +postscript +svg"
  14. RDEPEND="dev-haskell/mtl:=[profile?]
  15. >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
  16. >=dev-lang/ghc-6.10.4:=
  17. x11-libs/cairo[svg?]"
  18. DEPEND="${RDEPEND}
  19. >=dev-haskell/gtk2hs-buildtools-0.12.5.1-r1:0=
  20. virtual/pkgconfig
  21. "
  22. src_prepare() {
  23. sed -e "s@#include<cairo-features.h>@#define $(usex amd64 __x86_64__ __i386__)\n#include<cairo-features.h>@" \
  24. -i "${S}"/Graphics/Rendering/Cairo.hs \
  25. || die "Could not define ABI in Graphics/Rendering/Cairo.hs"
  26. }
  27. src_configure() {
  28. haskell-cabal_src_configure \
  29. $(cabal_flag pdf cairo_pdf) \
  30. $(cabal_flag postscript cairo_ps) \
  31. $(cabal_flag svg cairo_svg)
  32. }