concurrent-extra-0.7.0.10.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.4.6.9999
  5. CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
  6. inherit haskell-cabal
  7. DESCRIPTION="Extra concurrency primitives"
  8. HOMEPAGE="https://github.com/basvandijk/concurrent-extra"
  9. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0/${PV}"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. RDEPEND=">=dev-haskell/stm-2.1.2.1:=[profile?] <dev-haskell/stm-2.5:=[profile?]
  15. >=dev-haskell/unbounded-delays-0.1:=[profile?] <dev-haskell/unbounded-delays-0.2:=[profile?]
  16. >=dev-lang/ghc-7.4.1:=
  17. "
  18. DEPEND="${RDEPEND}
  19. >=dev-haskell/cabal-1.8
  20. test? ( >=dev-haskell/async-2.0
  21. >=dev-haskell/hunit-1.2.2 <dev-haskell/hunit-1.4
  22. >=dev-haskell/random-1.0 <dev-haskell/random-1.2
  23. >=dev-haskell/test-framework-0.2.4 <dev-haskell/test-framework-0.9
  24. >=dev-haskell/test-framework-hunit-0.2.4 <dev-haskell/test-framework-hunit-0.4 )
  25. "
  26. src_prepare() {
  27. cabal_chdeps \
  28. 'async >= 2.0 && < 2.1' 'async >= 2.0'
  29. }