esqueleto-2.4.3-r1.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # ebuild generated by hackport 0.4.7.9999
  5. #hackport: flags: -mysql,-postgresql
  6. CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
  7. inherit haskell-cabal
  8. DESCRIPTION="Type-safe EDSL for SQL queries on persistent backends"
  9. HOMEPAGE="https://github.com/prowdsponsor/esqueleto"
  10. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  11. LICENSE="BSD"
  12. SLOT="0/${PV}"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. RDEPEND="dev-haskell/blaze-html:=[profile?]
  16. >=dev-haskell/conduit-1.1:=[profile?]
  17. dev-haskell/monad-logger:=[profile?]
  18. >=dev-haskell/persistent-2.1.1.7:=[profile?]
  19. >=dev-haskell/resourcet-1.1:=[profile?]
  20. >=dev-haskell/tagged-0.2:=[profile?]
  21. >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
  22. >=dev-haskell/transformers-0.2:=[profile?]
  23. >=dev-haskell/unordered-containers-0.2:=[profile?]
  24. >=dev-lang/ghc-7.4.1:=
  25. "
  26. DEPEND="${RDEPEND}
  27. >=dev-haskell/cabal-1.8
  28. test? ( >=dev-haskell/hspec-1.8
  29. dev-haskell/hunit
  30. dev-haskell/monad-control
  31. >=dev-haskell/monad-logger-0.3
  32. >=dev-haskell/persistent-sqlite-2.1
  33. >=dev-haskell/persistent-template-2.1
  34. dev-haskell/quickcheck )
  35. "
  36. PATCHES=("${FILESDIR}"/${P}-persistent-2.5.patch)
  37. src_configure() {
  38. haskell-cabal_src_configure \
  39. --flag=-mysql \
  40. --flag=-postgresql
  41. }