graphviz-2999.18.0.2-r1.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.4.6.9999
  5. #hackport: flags: -test-parsing
  6. CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
  7. inherit haskell-cabal
  8. DESCRIPTION="Bindings to Graphviz for graph visualisation"
  9. HOMEPAGE="http://projects.haskell.org/graphviz/"
  10. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  11. LICENSE="BSD"
  12. SLOT="0/${PV}"
  13. KEYWORDS="amd64 x86"
  14. IUSE=""
  15. RESTRICT=test # too slow
  16. RDEPEND=">=dev-haskell/colour-2.3:=[profile?] <dev-haskell/colour-2.4:=[profile?]
  17. >=dev-haskell/dlist-0.5:=[profile?] <dev-haskell/dlist-0.8:=[profile?]
  18. >=dev-haskell/fgl-5.4:=[profile?] <dev-haskell/fgl-5.6:=[profile?]
  19. >=dev-haskell/polyparse-1.9:=[profile?]
  20. >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
  21. dev-haskell/text:=[profile?]
  22. >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
  23. >=dev-haskell/wl-pprint-text-1.1.0.0:=[profile?] <dev-haskell/wl-pprint-text-1.2.0.0:=[profile?]
  24. >=dev-lang/ghc-7.4.1:=
  25. "
  26. DEPEND="${RDEPEND}
  27. >=dev-haskell/cabal-1.14
  28. test? ( >=dev-haskell/fgl-arbitrary-0.2 <dev-haskell/fgl-arbitrary-0.3
  29. >=dev-haskell/quickcheck-2.3 <dev-haskell/quickcheck-2.9 )
  30. "
  31. src_prepare() {
  32. cabal_chdeps \
  33. 'polyparse >=1.9 && <1.12' 'polyparse >=1.9'
  34. }
  35. src_configure() {
  36. haskell-cabal_src_configure \
  37. --flag=-test-parsing
  38. }