graphviz-2999.18.1.2.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # ebuild generated by hackport 0.5.9999
  5. #hackport: flags: -test-parsing
  6. CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
  7. inherit haskell-cabal
  8. DESCRIPTION="Bindings to Graphviz for graph visualisation"
  9. HOMEPAGE="http://projects.haskell.org/graphviz/"
  10. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  11. LICENSE="BSD"
  12. SLOT="0/${PV}"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. RDEPEND=">=dev-haskell/colour-2.3:=[profile?] <dev-haskell/colour-2.4:=[profile?]
  16. >=dev-haskell/dlist-0.5:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
  17. >=dev-haskell/fgl-5.4:=[profile?] <dev-haskell/fgl-5.6:=[profile?]
  18. >=dev-haskell/polyparse-1.9:=[profile?] <dev-haskell/polyparse-1.13:=[profile?]
  19. >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
  20. dev-haskell/text:=[profile?]
  21. >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
  22. >=dev-haskell/wl-pprint-text-1.1.0.0:=[profile?] <dev-haskell/wl-pprint-text-1.2.0.0:=[profile?]
  23. >=dev-lang/ghc-7.4.1:=
  24. "
  25. DEPEND="${RDEPEND}
  26. >=dev-haskell/cabal-1.14
  27. test? ( >=dev-haskell/fgl-arbitrary-0.2 <dev-haskell/fgl-arbitrary-0.3
  28. >=dev-haskell/quickcheck-2.3 <dev-haskell/quickcheck-2.10 )
  29. "
  30. src_configure() {
  31. haskell-cabal_src_configure \
  32. --flag=-test-parsing
  33. }