hlint-1.8.57.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.3.6.9999
  5. CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
  6. inherit haskell-cabal elisp-common
  7. DESCRIPTION="Source code suggestions"
  8. HOMEPAGE="http://community.haskell.org/~ndm/hlint/"
  9. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0/${PV}"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="emacs"
  14. RDEPEND=">=dev-haskell/cpphs-1.11:=[profile?]
  15. >=dev-haskell/haskell-src-exts-1.14:=[profile?] <dev-haskell/haskell-src-exts-1.15:=[profile?]
  16. >=dev-haskell/hscolour-1.17:=[profile?]
  17. >=dev-haskell/transformers-0.0:=[profile?]
  18. >=dev-haskell/uniplate-1.5:=[profile?]
  19. >=dev-lang/ghc-6.10.4:=
  20. "
  21. DEPEND="${RDEPEND}
  22. >=dev-haskell/cabal-1.6.0.3
  23. "
  24. SITEFILE="60${PN}-gentoo.el"
  25. src_configure() {
  26. local threaded_flag=""
  27. if $(ghc-supports-threaded-runtime); then
  28. threaded_flag="--flags=threaded"
  29. else
  30. threaded_flag="--flags=-threaded"
  31. fi
  32. cabal_src_configure \
  33. $threaded_flag
  34. }
  35. src_compile() {
  36. cabal_src_compile
  37. use emacs && elisp-compile data/hs-lint.el
  38. }
  39. src_install() {
  40. cabal_src_install
  41. if use emacs; then
  42. elisp-install ${PN} data/*.el data/*.elc || die "elisp-install failed."
  43. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  44. fi
  45. doman data/hlint.1
  46. }
  47. pkg_postinst() {
  48. ghc-package_pkg_postinst
  49. use emacs && elisp-site-regen
  50. }
  51. pkg_postrm() {
  52. use emacs && elisp-site-regen
  53. }