hps-0.15.ebuild 752 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # ebuild generated by hackport 0.5.9999
  5. CABAL_FEATURES="lib profile haddock hoogle hscolour"
  6. inherit haskell-cabal
  7. DESCRIPTION="Haskell Postscript"
  8. HOMEPAGE="http://rd.slavepianos.org/?t=hps"
  9. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0/${PV}"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="build-exec"
  14. RDEPEND=">=dev-haskell/hcg-minus-0.15:=[profile?] <dev-haskell/hcg-minus-0.16:=[profile?]
  15. >=dev-lang/ghc-7.4.1:=
  16. build-exec? ( dev-haskell/random:=[profile?] )
  17. "
  18. DEPEND="${RDEPEND}
  19. >=dev-haskell/cabal-1.8
  20. "
  21. src_configure() {
  22. haskell-cabal_src_configure \
  23. $(cabal_flag build-exec build-exec)
  24. }