shakespeare-1.2.1.1.ebuild 932 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.3.6.9999
  5. CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
  6. inherit haskell-cabal
  7. DESCRIPTION="A toolkit for making compile-time interpolated templates"
  8. HOMEPAGE="http://www.yesodweb.com/book/shakespearean-templates"
  9. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  10. LICENSE="MIT"
  11. SLOT="0/${PV}"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="test_export"
  14. RDEPEND=">=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-4:=[profile?]
  15. >=dev-haskell/system-fileio-0.3:=[profile?]
  16. >=dev-haskell/system-filepath-0.4:=[profile?]
  17. >=dev-haskell/text-0.7:=[profile?]
  18. >=dev-lang/ghc-6.12.1:=
  19. "
  20. DEPEND="${RDEPEND}
  21. >=dev-haskell/cabal-1.8.0.2
  22. test? ( >=dev-haskell/hspec-1.3 )
  23. "
  24. src_configure() {
  25. haskell-cabal_src_configure \
  26. $(cabal_flag test_export test_export)
  27. }