warp-tls-3.1.5.ebuild 1011 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.4.6.9999
  5. #hackport: flags: +tls_1_1_3
  6. CABAL_FEATURES="lib profile haddock hoogle hscolour"
  7. inherit haskell-cabal
  8. DESCRIPTION="HTTP over TLS support for Warp via the TLS package"
  9. HOMEPAGE="https://github.com/yesodweb/wai"
  10. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  11. LICENSE="MIT"
  12. SLOT="0/${PV}"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. RDEPEND=">=dev-haskell/cprng-aes-0.5.0:=[profile?]
  16. >=dev-haskell/data-default-class-0.0.1:=[profile?]
  17. >=dev-haskell/network-2.2.1:=[profile?]
  18. dev-haskell/streaming-commons:=[profile?]
  19. >=dev-haskell/tls-1.3.2:=[profile?]
  20. >=dev-haskell/wai-3.0.4:=[profile?] <dev-haskell/wai-3.1:=[profile?]
  21. >=dev-haskell/warp-3.1.7:=[profile?] <dev-haskell/warp-3.2:=[profile?]
  22. >=dev-lang/ghc-7.4.1:=
  23. "
  24. DEPEND="${RDEPEND}
  25. >=dev-haskell/cabal-1.6
  26. "
  27. src_configure() {
  28. haskell-cabal_src_configure \
  29. --flag=tls_1_1_3
  30. }