warp-3.2.11.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # ebuild generated by hackport 0.5.1.9999
  5. #hackport: flags: -network-bytestring
  6. CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
  7. inherit haskell-cabal
  8. DESCRIPTION="A fast, light-weight web server for WAI applications"
  9. HOMEPAGE="https://github.com/yesodweb/wai"
  10. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  11. LICENSE="MIT"
  12. SLOT="0/${PV}"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE="+allow-sendfilefd warp-debug"
  15. RDEPEND="dev-haskell/async:=[profile?]
  16. >=dev-haskell/auto-update-0.1.3:=[profile?] <dev-haskell/auto-update-0.2:=[profile?]
  17. >=dev-haskell/blaze-builder-0.4:=[profile?]
  18. dev-haskell/bytestring-builder:=[profile?]
  19. >=dev-haskell/case-insensitive-0.2:=[profile?]
  20. dev-haskell/hashable:=[profile?]
  21. dev-haskell/http-date:=[profile?]
  22. >=dev-haskell/http-types-0.8.5:=[profile?]
  23. >=dev-haskell/http2-1.6:=[profile?] <dev-haskell/http2-1.7:=[profile?]
  24. >=dev-haskell/iproute-1.3.1:=[profile?]
  25. >=dev-haskell/network-2.3:=[profile?]
  26. >=dev-haskell/simple-sendfile-0.2.7:=[profile?] <dev-haskell/simple-sendfile-0.3:=[profile?]
  27. >=dev-haskell/stm-2.3:=[profile?]
  28. >=dev-haskell/streaming-commons-0.1.10:=[profile?]
  29. dev-haskell/text:=[profile?]
  30. >=dev-haskell/unix-compat-0.2:=[profile?]
  31. >=dev-haskell/vault-0.3:=[profile?]
  32. >=dev-haskell/wai-3.2:=[profile?] <dev-haskell/wai-3.3:=[profile?]
  33. dev-haskell/word8:=[profile?]
  34. >=dev-lang/ghc-7.4.1:=
  35. "
  36. DEPEND="${RDEPEND}
  37. >=dev-haskell/cabal-1.8
  38. test? ( >=dev-haskell/doctest-0.10.1
  39. >=dev-haskell/hspec-1.3
  40. dev-haskell/http
  41. dev-haskell/hunit
  42. >=dev-haskell/lifted-base-0.1
  43. dev-haskell/quickcheck
  44. dev-haskell/silently
  45. >=dev-haskell/transformers-0.2.2 )
  46. "
  47. src_configure() {
  48. haskell-cabal_src_configure \
  49. $(cabal_flag allow-sendfilefd allow-sendfilefd) \
  50. --flag=-network-bytestring \
  51. $(cabal_flag warp-debug warp-debug)
  52. }