j-701-r2.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="Modern, high-level, general-purpose, high-performance programming language"
  5. HOMEPAGE="http://jsoftware.com"
  6. SRC_URI="http://www.jsoftware.com/download/${PN}${PV}_b_source.tar.gz"
  7. inherit eutils
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND="${DEPEND}"
  14. S="${WORKDIR}/jgplsrc"
  15. src_prepare() {
  16. sed -i -e 's:make libj >& make.txt:make libj:' bin/build_libj || die
  17. sed -i -e 's:W1,soname:Wl,-soname:' bin/jconfig || die
  18. if use amd64; then
  19. sed -i -e 's/bits=32/bits=64/' bin/jconfig || die
  20. fi
  21. }
  22. src_compile() {
  23. bin/jconfig || die
  24. bin/build_defs || die
  25. bin/build_libj || die
  26. bin/build_jconsole || die
  27. }
  28. src_install() {
  29. # since this appears to use hardcoded relative paths
  30. # there's no sane way to put it in the normal filesystem hierarchy
  31. mkdir -p "${D}/opt/j"
  32. cp -r j/* "${D}/opt/j" || die
  33. mkdir -p "${D}/usr/bin"
  34. echo -e "#!/bin/sh\n/opt/j/bin/jconsole" > "${D}/usr/bin/jc" || die
  35. chmod +x "${D}/usr/bin/jc"
  36. }