luasystem-0.2.0_p0.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. # The below is the upstream version number. The -x suffix should be kept
  6. # in sync with the _px suffix in the ebuild version.
  7. MY_PV="0.2.0-0"
  8. DESCRIPTION="platform independent system calls for lua"
  9. HOMEPAGE="https://github.com/LuaDist2/luasystem"
  10. SRC_URI="https://github.com/LuaDist2/luasystem/archive/${MY_PV}.tar.gz ->
  11. ${P}.tar.gz"
  12. LICENSE="MIT"
  13. SLOT="0"
  14. KEYWORDS="amd64 ~x86"
  15. IUSE=""
  16. COMMON_DEPEND=">=dev-lang/lua-5.1:="
  17. DEPEND="${COMMON_DEPEND}
  18. virtual/pkgconfig"
  19. RDEPEND="${COMMON_DEPEND}"
  20. S="${WORKDIR}/${PN}-${MY_PV}"
  21. PATCHES=(
  22. "${FILESDIR}"/${P}-fix-makefile.patch
  23. )
  24. src_compile() {
  25. emake CC="$(tc-getCC)" MYCFLAGS="${CFLAGS}" \
  26. LD="$(tc-getCC)" MYLDFLAGS="${LDFLAGS}"
  27. }
  28. src_install () {
  29. insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
  30. doins -r system
  31. exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/system
  32. doexe src/core.so
  33. dodoc README.md
  34. }