pecl-raphf-1.1.2-r1.ebuild 748 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. PHP_EXT_NAME="raphf"
  5. PHP_EXT_INI="yes"
  6. PHP_EXT_ZENDEXT="no"
  7. PHP_EXT_ECONF_ARGS=""
  8. USE_PHP="php5-6 php7-0 php7-1"
  9. inherit php-ext-pecl-r3
  10. USE_PHP="php5-6"
  11. KEYWORDS="amd64 x86"
  12. DESCRIPTION="A reusable, persistent handle and resource factory API"
  13. LICENSE="BSD-2"
  14. SLOT="0"
  15. IUSE=""
  16. PDEPEND="
  17. php_targets_php7-0? ( dev-php/pecl-raphf:7[php_targets_php7-0] )
  18. php_targets_php7-1? ( dev-php/pecl-raphf:7[php_targets_php7-1] )"
  19. src_prepare() {
  20. if use php_targets_php5-6 ; then
  21. php-ext-source-r3_src_prepare
  22. else
  23. default_src_prepare
  24. fi
  25. }
  26. src_install() {
  27. if use php_targets_php5-6 ; then
  28. php-ext-pecl-r3_src_install
  29. fi
  30. }