guile-gnome-platform-2.16.2.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. AUTOTOOLS_AUTORECONF=true
  5. inherit autotools-utils multilib
  6. DESCRIPTION="Guile Scheme code that wraps the GNOME developer platform"
  7. HOMEPAGE="https://www.gnu.org/software/guile-gnome/"
  8. SRC_URI="https://ftp.gnu.org/pub/gnu/guile-gnome/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE="static-libs"
  13. RDEPEND="
  14. dev-libs/atk
  15. >=dev-libs/g-wrap-1.9.14
  16. dev-libs/glib:2
  17. dev-scheme/guile:12
  18. dev-scheme/guile-cairo
  19. dev-scheme/guile-lib
  20. gnome-base/gconf:2
  21. gnome-base/gnome-vfs:2
  22. gnome-base/libbonobo
  23. gnome-base/libglade:2.0
  24. gnome-base/libgnomecanvas
  25. gnome-base/libgnomeui
  26. gnome-base/orbit:2
  27. x11-libs/gtk+:2
  28. x11-libs/pango"
  29. DEPEND="${RDEPEND}
  30. virtual/pkgconfig"
  31. #needs guile with networking
  32. RESTRICT=test
  33. MAKEOPTS+=" -j1"
  34. src_prepare() {
  35. PATCHES=(
  36. "${FILESDIR}/2.16.1-glib-single-include.patch"
  37. )
  38. autotools-utils_src_prepare
  39. }
  40. src_compile() {
  41. autotools-utils_src_compile \
  42. guilegnomedir=/usr/share/guile/site \
  43. guilegnomelibdir=/usr/$(get_libdir)
  44. }
  45. src_install() {
  46. autotools-utils_src_install \
  47. guilegnomedir=/usr/share/guile/site \
  48. guilegnomelibdir=/usr/$(get_libdir)
  49. }