quake3-demo-1.11-r1.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils unpacker games
  5. DESCRIPTION="the playable demo of Quake III Arena by Id Software"
  6. HOMEPAGE="http://www.idsoftware.com/games/quake/quake3-arena/"
  7. SRC_URI="mirror://idsoftware/quake3/linux/linuxq3ademo-${PV}-6.x86.gz.sh
  8. mirror://3dgamers/quake3arena/linuxq3ademo-${PV}-6.x86.gz.sh"
  9. LICENSE="Q3AEULA"
  10. SLOT="0"
  11. KEYWORDS="-* amd64 x86"
  12. IUSE="dedicated"
  13. RESTRICT="strip"
  14. RDEPEND="sys-libs/glibc
  15. amd64? ( sys-libs/glibc[multilib] )
  16. dedicated? ( app-misc/screen )
  17. !dedicated? (
  18. >=virtual/opengl-7.0-r1[abi_x86_32(-)]
  19. >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
  20. >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
  21. )"
  22. S=${WORKDIR}
  23. dir=${GAMES_PREFIX_OPT}/${PN}
  24. Ddir=${D}/${dir}
  25. QA_PREBUILT="${dir:1}/q3ded.x86
  26. ${dir:1}/q3demo.x86"
  27. src_unpack() {
  28. unpack_makeself
  29. }
  30. src_install() {
  31. insinto "${dir}"
  32. doins -r Help demoq3
  33. doins README icon.*
  34. exeinto "${dir}"
  35. newexe bin/x86/glibc-2.0/q3ded q3ded.x86
  36. games_make_wrapper q3ded ./q3ded.x86 "${dir}" "${dir}"
  37. if ! use dedicated; then
  38. newexe bin/x86/glibc-2.0/q3demo q3demo.x86
  39. games_make_wrapper q3demo ./q3demo.x86 "${dir}" "${dir}"
  40. make_desktop_entry q3demo "Quake III (Demo)"
  41. fi
  42. prepgamesdirs
  43. }
  44. pkg_postinst() {
  45. games_pkg_postinst
  46. if ! use dedicated; then
  47. elog "To play the game run:"
  48. elog " q3demo"
  49. fi
  50. echo
  51. elog "To start the gameserver, run:"
  52. elog " q3ded"
  53. }