tenebrae-1.04.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. #ECVS_SERVER="cvs.tenebrae.sourceforge.net:/cvsroot/tenebrae"
  5. #ECVS_MODULE="tenebrae_0"
  6. #inherit cvs
  7. inherit eutils games
  8. DESCRIPTION="adds stencil shadows and per pixel lights to quake"
  9. HOMEPAGE="http://tenebrae.sourceforge.net/"
  10. SRC_URI="mirror://sourceforge/tenebrae/tenebraedata.zip
  11. mirror://gentoo/${P}.tbz2"
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="x86"
  15. IUSE=""
  16. RDEPEND="virtual/opengl
  17. virtual/glu
  18. media-libs/libpng:0
  19. x11-libs/libXxf86vm
  20. x11-libs/libXxf86dga"
  21. DEPEND="${RDEPEND}
  22. x11-proto/xextproto
  23. x11-proto/xf86dgaproto
  24. x11-proto/xf86vidmodeproto
  25. app-arch/unzip"
  26. S=${WORKDIR}
  27. src_unpack() {
  28. if [[ -z ${ECVS_MODULE} ]] ; then
  29. unpack ${A}
  30. else
  31. cvs_src_unpack
  32. fi
  33. }
  34. src_prepare() {
  35. cd tenebrae_0
  36. sed -i \
  37. -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
  38. gl_warp.c || die
  39. epatch \
  40. "${FILESDIR}"/${PV}-glhax.patch \
  41. "${FILESDIR}"/${P}-exec-stack.patch
  42. cd linux
  43. sed \
  44. -e "/^LDFLAGS/s:=:+=:" \
  45. -e "s:-mpentiumpro -O6:${CFLAGS}:" \
  46. Makefile.i386linux > Makefile || die
  47. }
  48. src_compile() {
  49. cd "${S}"/tenebrae_0/linux
  50. emake MASTER_DIR="${GAMES_DATADIR}/quake1" build_release
  51. }
  52. src_install() {
  53. newgamesbin tenebrae_0/linux/release*/bin/tenebrae.run tenebrae
  54. insinto "${GAMES_DATADIR}/quake1/tenebrae"
  55. doins "${WORKDIR}"/tenebrae/*
  56. dodoc tenebrae_0/linux/README "${WORKDIR}"/Tenebrae_Readme.txt
  57. prepgamesdirs
  58. }