arrows-0.6.ebuild 933 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit games
  5. DESCRIPTION="simple maze-like game where you navigate around and destroy arrows"
  6. HOMEPAGE="http://noreason.ca/?file=software"
  7. SRC_URI="http://noreason.ca/data/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86"
  11. IUSE=""
  12. RDEPEND=">=x11-libs/gtk+-2.4:2"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_prepare() {
  16. # Modify path to data
  17. sed -i \
  18. -e "s:arrfl:${GAMES_DATADIR}/${PN}/arrfl:" \
  19. -e 's:nm\[9:nm[35:' \
  20. -e 's:nm\[6:nm[30:' \
  21. -e 's:nm\[7:nm[31:' \
  22. game.c \
  23. || die 'sed failed'
  24. sed -i \
  25. -e '/^CC /d' \
  26. -e '/CCLIBS/s:$: $(LDFLAGS):' \
  27. Makefile \
  28. || die 'sed failed'
  29. }
  30. src_compile() {
  31. make clean || die "make clean failed"
  32. emake CCOPTS="${CFLAGS}"
  33. }
  34. src_install() {
  35. dogamesbin arrows
  36. insinto "${GAMES_DATADIR}/${PN}"
  37. doins arrfl*
  38. dodoc README
  39. prepgamesdirs
  40. }